Shopping Cart System Requirements- CartIt

CartIt has been used successfully since 1996 on shared hosting accounts. Over the last several years however, it has become increasingly clear that commodity hosting accounts can NOT be considered secure. In the year 2009 and beyond, if you are running an Internet based business, you should have your own dedicated server or at least a Virtual Private Server (VPS). A Linux based VPS can be had today for about $40 per month- about the cost of a hosting account a few years ago. Please consider using a private server or a dedicated Windows server for your business- and don't buy based on price alone.

Windows or UNIX/Linux Based Web Servers

Since 1996 we have had no problem on any UNIX platform, including all the Linux flavors of Unix-like OS's. A Windows-based Web server requires PERL. Almost all Windows Web based hosting account servers should have Active State PERL installed.


A "private" location to store CGI applications on your Web server. The CGI-BIN name is simply a convention. Your provider may call it something else E.G. cgi-local or similar.

Sendmail on UNIX/Linux

Sendmail is a standard mail transport system on UNIX systems. It is extremely rare that a UNIX or Linux system does not have Sendmail or equivalent.

SMTP Server on Windows

For Windows based hosting, you must have access to a valid SMTP server. SMTP is a core feature provided by most hosting companies.

PERL Version 5.x

PERL is required on Windows and UNIX based systems. PERL is usually installed on every UNIX and Linux based system. On Windows, it is very common and on commercial Windows hosting accounts, it is almost unheard of to not have PERL installed. PERL for Windows can be found at:

Power Extensions

CartIt has the ability to perform real-time credit card processing and real-time shipping quotes.

You will need an account with the shipping service provider and/or the real-time credit card providers. For these extensions to function on your Web site, you or your Internet provider must have the required PERL modules installed.

Required Installed PERL Modules:


CartItShoppingCart can not and will not provide support for module installation on hosting accounts, as many Internet providers have different requirements, limitations and rules regarding module usage. In other words, we have no control over the usage of the Web server. Before purchasing CartIt, please confirm with your Internet provider that these modules are installed or that your CartIt Commerce Developer can install them.

Module installation takes several minutes and should not be limited to your Web site alone. Any service-oriented Internet provider should be able to install these extensions for you in minutes, if they are not already installed. UNIX/Linux Modules can be obtained from CPAN, ActiveState has windows-ported versions of these modules. Installers should obtain these themselves for easy installation.

Server SSL Certificate

It is strongly recommended that you have a server certificate for your Web site. A certificate can be obtained from your hosting company and they should have some type of document published on their Web site about how to obtain a certificate, or you may contact them directly.

Limitations: CartIt can also use Shared SSL from your Internet provider, however, this shared SSL must be a single server environment. CartIt will not function if it requires two separate log-ons or accounts for SSL and non-SSL environments. Shared SSL is NOT recommended.


CommerceBuddy System Requirements

CartIt 8.0 also requires CommerceBuddy for fetching orders. CommerceBuddy is integral to CartIt.

- Windows 9x/NT/2000/XP/Vista
- Microsoft Internet Explorer 5.0 or higher
- Pentium III or higher
- 8 MB Hard Disk Space for Application Files
- 15-20MB to Account for Database Growth
- Internet Access